use.cloudshare.com is down
Incident Report for CloudShare
Resolved
This incident has been resolved.
Posted Nov 20, 2019 - 20:05 GMT+08:00
Investigating
We are currently investigating the issue and working on restoring the service asap.
Posted Nov 20, 2019 - 19:52 GMT+08:00
This incident affected: Web Interface, API, Cloud Folders, Payment System, Reports, and Email Invitations.