CloudFolders' machines are under maintenance
Incident Report for CloudShare
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 02, 2018 - 01:44 PDT
Investigating
Imports/Exports will not work
Posted 3 months ago. Sep 02, 2018 - 01:04 PDT
This incident affected: Cloud Folders.