Service Provider Outage

Incident Report for CloudShare

Resolved

This incident has been resolved.
Posted Feb 10, 2026 - 19:44 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 10, 2026 - 19:21 UTC

Update

The external DNS provider outage is still ongoing. DNSimple has confirmed they are actively working to restore service.

The issue remains external to CloudShare infrastructure. Some customers may continue to experience intermittent access issues.

DNSimple’s latest update and ongoing status can be found here:
https://dnsimple.statuspage.io/incidents/s5rkdrmr3d2d

We are monitoring the situation closely and will continue to provide updates as new information becomes available.
Posted Feb 10, 2026 - 18:41 UTC

Update

We are continuing to work on a fix for this issue.
Posted Feb 10, 2026 - 18:17 UTC

Update

We are continuing to work on a fix for this issue.
Posted Feb 10, 2026 - 18:16 UTC

Update

We are continuing to work on a fix for this issue.
Posted Feb 10, 2026 - 18:09 UTC

Identified

We are currently experiencing service disruptions affecting some customer environments due to an ongoing outage at one of our external DNS providers (DNSimple), which manages portions of our public DNS infrastructure.

This issue is external to CloudShare’s infrastructure. We are actively monitoring the situation and are in communication with the provider.

DNSimple is tracking this incident on their status page:
https://dnsimple.statuspage.io/incidents/s5rkdrmr3d2d

Some customers may continue to experience intermittent access issues until the provider fully resolves the outage.

We will continue to share updates as more information becomes available.
Posted Feb 10, 2026 - 18:06 UTC
This incident affected: Web Interface, API and Remote Access Services (Remote Access Services - Miami, Remote Access Services - Amsterdam, Remote Access Services - Singapore).