Storage Performance degradation in Amsterdam
Incident Report for CloudShare
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 27, 2018 - 08:16 PDT
Update
We are continuing to work on a fix for this issue.
Posted 3 months ago. Jun 27, 2018 - 08:16 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Jun 27, 2018 - 06:32 PDT
This incident affected: Storage (Storage - Amsterdam).