Overall slowness in loading the Web Application
Incident Report for CloudShare
Resolved
This incident has been resolved.
Posted 2 months ago. Jun 06, 2018 - 09:33 PDT
Investigating
We are sorry for the inconvenience but we are currently facing degrade performance in load of our Web Application. We are looking into it and will resolve the issue shortly.
Posted 2 months ago. Jun 06, 2018 - 08:31 PDT
This incident affected: Web Interface.