Class creation problem - blank page
Incident Report for CloudShare
Resolved
This incident has been resolved.
Posted Feb 15, 2021 - 07:42 UTC
Investigating
We experience an issue with the Class creation page in use.cloudshare.com. We are sorry for the inconvenience and doing as best as we can to fix this issue asap.
Posted Feb 15, 2021 - 07:23 UTC
This incident affected: Web Interface.