RDP Errors
Incident Report for CloudShare
Resolved
This incident has been resolved.
Posted almost 2 years ago. Jul 19, 2016 - 16:35 PDT
Identified
We are currently experiencing an issue with some environments on our primary data center. As a result some remote connections may take longer to establish and perform slowly. As a workaround, please connect to machines using Direct RDP or the RDP file.
Our data center has been alerted and we will continue to update on the situation.
Posted almost 2 years ago. Jul 19, 2016 - 13:24 PDT