Outgoing Email Delays
Incident Report for CloudShare
Resolved
The issue with our outgoing mail system has been resolved.
Posted over 2 years ago. Jan 18, 2016 - 10:52 PST
Identified
We are currently experiencing problems with part of our outgoing mail system.
As a result some of the outgoing emails may be delayed. We are working to solve the problem.
Posted over 2 years ago. Jan 18, 2016 - 10:20 PST