Outgoing Email Delays
Incident Report for CloudShare
Resolved
Service has returned to normal. Thank you again for your patience.
Posted 6 months ago. Feb 01, 2018 - 12:27 PST
Investigating
We are currently experiencing problems with part of our outgoing mail system. As a result some outgoing emails may be delayed. We are working to resolve the issue.
Posted 6 months ago. Feb 01, 2018 - 10:49 PST